Advertisements

#AlienVault #OSSIM Operation was not completed due to a database error

Every so often I get the Operation was not completed due to a database error error in the web interface. I’ve tried a reboot and no joy, so far I have used the console to apply updates and then it starts working…. go figure. I haven’t really researched it beyond that point 🙂

Advertisements

imitating a serial port

From this http://stackoverflow.com/questions/1605721/faking-an-rs232-serial-port

I use com0com – With Signed Driver, on windows 7 x64 to emulate COM3 AND COM4 as a pair.

Then i use COM Dataport Emulator to write data to COM3 and receive on COM 4.

autoit _INetSmtpMail Mail failed with error code 50, solution

With exchange 2003 at least

From here

https://www.autoitscript.com/forum/topic/66691-_inetsmtpmail-mail-failed-with-error-code-50/

You need to use a -1 for the optional parameter

$sFirst [optional] string sent before helo for the smtp server connection (by default {SPACE}). To not send any character this parameter must equal -1, some SMTP server required it.

From https://www.autoitscript.com/autoit3/files/beta/autoit/docs/libfunctions/_INetSmtpMail.htm

So it ends up being

Local $iResponse = _INetSmtpMail($s_SmtpServer, $s_FromName, $s_FromAddress, $s_ToAddress, $s_Subject, $as_Body,”,-1)

Qlikview Binary Error can’t find file

Well I had forgot to end the statement with a semicolon!

This

Binary File.qvw;

Not this

Binary File

Visual Studio’s horrendous colorization of CDATA XML blocks in VB.

Answer from here

http://stackoverflow.com/questions/16680026/visual-studios-horrendous-colorization-of-cdata-xml-blocks-in-vb

Tools > Options > Environment > Fonts and Colors > show setting for - text editor.

VB XML CData Section

So, so, so awful.