Advertisements

Configuring Ether-Channel for Vmware ESX 3.5 on a Cisco 4503 Catalyst

Find this post interesting? Do you like interesting things? Maybe you would like my invention, a connectible candle called a WickBrick!

Get one here http://wickbrick.etsy.com/

WickBrick

I am by no means a Cisco expert, not even close… so take this post with a huge grain of salt. It hopefully will help you at least get close to what you want, which is Nic Teaming on your Vmware server.

In our case our vmware servers have 6 Nics, that are configured like this.

esx_network_settingsSo vmnic0 (zero)  is for the service console, nic1 is a service console and for vmotion, and nic2 – 5 are teamed for the virtual machines.

So, now on to the Cisco config. So by design, ESX handles the outgoing load balancing, but to get incoming load balancing you need to configure your switch. This post talks a little bit about it

http://virtrix.blogspot.com/2006/11/vmware-switch-load-balancing.html

And I think it is a similar setup. I notice that that post uses spanning-tree portfast trunk but I’m not sure what that does 🙂

So to configure your Cisco

telnet into your switch

put in your password

type en

put in your admin password

Ok, so we have three groups we wanted to setup,  group 1 on ports 1-4 group 2 on ports 5-8 group 3 on 9-12

so type config t

then

int range G2/1 – 4     (notice there is a space between the 1 and the dash and the dash and the 4) (I believe the g is for gigabit)

channel-group 1 mode on  (we had a consultant use access and then caused a network storm…. )

then type

exit

so if you type show run

you should see blade 2 ports 1 – 4 as part of channel-group 1 and the mode should be on

now type

interface port-channel1

sw tr en dot

sw mode tr

sw non

exit

and then

wr mem (to write out your settings)

Hopefully these notes help somebody out there!

You might also want to take a look at http://blog.scottlowe.org/2006/12/04/esx-server-nic-teaming-and-vlan-trunking/

Here is what my config looks like….

interface Port-channel1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface Port-channel2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface Port-channel3
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
!
interface GigabitEthernet2/2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
!
interface GigabitEthernet2/3
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
!
interface GigabitEthernet2/4
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
!
interface GigabitEthernet2/5
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 2 mode on
!
interface GigabitEthernet2/6
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 2 mode on
!
interface GigabitEthernet2/7
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 2 mode on
!
interface GigabitEthernet2/8
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 2 mode on
!
interface GigabitEthernet2/9
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 3 mode on
!
interface GigabitEthernet2/10
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 3 mode on
!
interface GigabitEthernet2/11
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 3 mode on
!
interface GigabitEthernet2/12
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 3 mode on
!

Advertisements

Compare Defraggler to DiskKeeper and Perfect Disk

Find this post interesting? Do you like interesting things? Maybe you would like my invention, a connectible candle called a WickBrick!

Get one here http://wickbrick.etsy.com/

WickBrick

According to my admittedly lame little test two runs of defraggler compares very favorably to DiskKeeper and Perfect Disk. This is how I performed my lame test. I got trial versions of DiskKeeper and Perfect Disk, I ran them to analyze the disk and made a note of the fragmentation. Then I ran defraggler, twice. Then I once again ran a scan with DiskKeeper and Perfect Disk and walaa they reported that the disk looked great. So what does this tell me? I’m not going to be buying DiskKeeper or Perfect Disk anytime soon!

Oh yeah, I am now installing defraggler into all of our Virtual Machines on the ESX server… it sounds like vmware recommends defragging virtual machines as well.

ESX A general system error occurred: The system returned an error. Communication with the virtual machine may have been interrupted.

Find this post interesting? Do you like interesting things? Maybe you would like my invention, a connectible candle called a WickBrick!

Get one here http://wickbrick.etsy.com/

WickBrick

So I went to start up a Virtual machine and it wouldn’t start up.

The error I got was

A general system error occurred: The system returned an error. Communication with the virtual machine may have been interrupted.

Oh great I’m thinking, this is the same error that the R2 bad patch was causing.

Well I narrowed it down to a problem with ESX1 and yet other machines could start virtual machines just fine.

After a bit of searching I found a command to restart the management service on the ESX server.

Logged on to ESX1

Then typed

service mgmt-vmware restart

Saw the service restart, and now I am able to start virtual machines just fine.

Time weirdness in ESX 3.5 vmware, how to fix

I originally ran into this post http://www.stefanschuller.com/guides/guide-keeping-time-in-esx.html which looked like a lot of work to get NTP up and running. Well I’m glad to say that with version 3.5 you can set the time in the virtual center GUI 🙂 just click on your ESX host, go to the configuration tab, then time configuration and you can set your ntp servers. Then you can set your VM’s to use the VM time synching and disable the windows time service.