Advertisements

More fun with the IBM 3690 X5, Bad status has been detected on 2 physical drives

So…. normally you get a new IBM server. You download the update express CD (Except now you have to download the IBM ToolsCenter Bootable Media Creator) update everything in the system then pop in the ServerGuide CD http://www-947.ibm.com/support/entry/portal/docdisplay?lndocid=SERV-GUIDE and then configure the RAID Adapter.

But then I got this:

Bad Status has been detected on 2 physical drives. What is going on here? Did we get to bad drives shipped to us? That doesn’t seem likely?

So I try all sorts of things, after the whole mezzanine issue (LINK) I’m starting to suspect all of the hardware. But everything seems to check out OK.

Then I remembered vaguely reading something about the RAID and UEFI. And there it was page 362 of the 580 page manual

Create a drive RAID array before installation. The ServeRAID management interface is
accessible via UEFI settings, by selecting System Settings  Adapters and UEFI
Drivers.

You open up this abomination from the UEFI screen

 

Then it brings up a screen where you can configure your JBOD disks as unconfirmed good. At that point you can use serverguide to set up the RAID…. very annoying.

 

Advertisements

2 Responses

  1. You saved me a lot of time thanks, this applied to my x3650 with serveRaid m1000 thanks for taking the time to share the knowledge

  2. thank you for this valuable info tonnie

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: